IIS 7.5 Logging with Sitecore 6.x in Integrated Pipeline Mode

by aboo bolaky 4. December 2010 21:48

When you run Sitecore 6.x in Integrated Pipeline Mode, You will notice that ALL IIS log entries contain the log entry for the resquest to the layout (aspx) page (instead of the actual sitecore item .e.g /ContactUs.aspx).

This problem is partly related to another issue outlined on Stack Overflow  [http://stackoverflow.com/questions/353541/iis7-rewritepath-and-iis-log-files]

If you run Sitecore in Classic Mode, the problem disappears. However, if you still wish to use Integrated Pipeline Mode, you will have to intercept the request  before the Sitecore HttpModule (Sitecore.Nexus.dll) gets involved.

Solution

Create a class that extends System.Web.IHttpModule  and  set the path back to the original value after the request has been processed but before the IIS logging module writes the log entry.

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.Web;

namespace Test
{
    public class RewritePath : IHttpModule
    {
        public void Init(HttpApplication context)
        {
            context.BeginRequest += OnBeginRequest;
            context.LogRequest += OnEndRequest;
        }

        static void OnBeginRequest(object sender, EventArgs e)
        {
            var app = (HttpApplication)sender;
            app.Context.Items["OriginalPath"] = app.Context.Request.Path;
        }

        static void OnEndRequest(object sender, EventArgs e)
        {
            var app = (HttpApplication)sender;
            var originalPath = app.Context.Items["OriginalPath"] as string;
            if (originalPath != null)
            {
                app.Context.RewritePath(originalPath);
            }
        }

        public void Dispose()
        {

        }

    }
}

Locate the Modules Section (under system.webServer ..remember we’re running in Integrated Pipeline Mode) and plug the module in BEFORE the Sitecore Nexus HttpModule

 

Here's what's captured when everything is compiled and deployed

 

Thanks Sitecore Support.

Tags: ,

.Net | Applications | Sitecore | Tips & Tricks

ListView with DataPager problem in .Net 4

by aboo bolaky 31. October 2010 00:36

I wanted to set the QueryStringField property of the DataPager dynamically. By default, if you do not specify this property, the pager works on a Postback Model.

On the other hand, if you do set the QueryStringField to something, it'll use the value that you set the QueryStringField to as a query string parameter and assign it the appropriate page number (IOW, it makes use of a query string parameter to change the page view)

The declarative and code-behind files are simple enough..

 

 

public partial class _Default : System.Web.UI.Page
{
        public string FieldName
        {
            get
            {
                return "PageID";
            }
        }
        protected override void OnInit(EventArgs e)
        {
            base.OnInit(e);
            
            ListView1.PagePropertiesChanging += new EventHandler(ListView1_PagePropertiesChanging);
            DataPager1.QueryStringField = FieldName;
           
        }
       

        void ListView1_PagePropertiesChanging(object sender, PagePropertiesChangingEventArgs e)
        {
            DataPager1.SetPageProperties(e.StartRowIndex, e.MaximumRows, false);
            BuildAndBind();

        }
        protected void Page_Load(object sender, EventArgs e)
        {
            if (!this.IsPostBack)
            {
                BuildAndBind();
            }

        }
        private void BuildAndBind()
        {
            ListView1.DataSource = BuildDataSource();
            ListView1.DataBind();

        }
        private List BuildDataSource()
        {
            Person a = new Person { FirstName = "A", LastName = "A", Address = "Address1" };
            Person b = new Person { FirstName = "B", LastName = "B", Address = "Address2" };
            Person c = new Person { FirstName = "C", LastName = "C", Address = "Address3" };
            Person d = new Person { FirstName = "D", LastName = "D", Address = "Address4" };
            Person e = new Person { FirstName = "E", LastName = "E", Address = "Address5" };
            Person f = new Person { FirstName = "F", LastName = "F", Address = "Address6" };
            Person g = new Person { FirstName = "G", LastName = "G", Address = "Address7" };
            Person h = new Person { FirstName = "H", LastName = "H", Address = "Address8" };
            Person i = new Person { FirstName = "I", LastName = "I", Address = "Address9" };
            Person j = new Person { FirstName = "J", LastName = "J", Address = "Address10" };
            Person k = new Person { FirstName = "K", LastName = "K", Address = "Address11" };
            Person l = new Person { FirstName = "L", LastName = "L", Address = "Address12" };
            Person m = new Person { FirstName = "M", LastName = "M", Address = "Address13" };


            List list = new List();
            
            list.Add(a);
            list.Add(b);
            list.Add(c);
            list.Add(d);
            list.Add(e);
            list.Add(f);
            list.Add(g);
            list.Add(h);
            list.Add(i);
            list.Add(j);
            list.Add(k);
            list.Add(l);
            list.Add(m);

            return list;
        }
    }

So far...So good..

Using the above example, since we've set the property in the code behind, we'd expect the pager to use a query string to drive the page view. Commenting the line out forces the pager to use a postback model.

What about .Net 4?

the above situations work when the project is set up to run in .NET 3.5 . However, this solution does not seem to work with .NET 4.0 at all. If we set the Target Framework to 4.0, the paging does not work if we want to force a QueryStringField at runtime :(

I've  attached a copy of the vs2010 website here

TestWebApp.zip (2.44 kb)

and the video (in mp4 format...) here

DataPager.mp4 (5.27 mb)

If there's anyone out there who can give me a clue on what's right or wrong, please drop me a few lines.. :)

 

Tags:

.Net | Asp.Net

Registering XSLT Extension Objects with the ASP XML control

by aboo bolaky 23. October 2009 07:01

I once inherited a sublayout that inlcuded an asp:xml control. The asp:xml control was there to handle and display an xml feed from another system, while the rest of the sublayout concentrated on rendering related feed content from Sitecore. The presentation of the xml feed was handled via an xlst rendering.

In this particular situation, I made use use of XSL extensions in the XSLT file. Registering the XSL Extension was fairly easy.

   
<xslExtensions>   
	<extension mode="on" type="Utils.XslHelper, Utils"
	           namespace="http://www.sitecore.net/Utils" 
		   singleInstance="true" />
	   .....
</xslExtensions>



Registering the extension in the xsl file

<xsl:stylesheet version="1.0" xmlns:xsl="http://www.w3.org/1999/XSL/Transform"
 xmlns:MyExtension="http://www.sitecore.net/Utils"
 exclude-result-prefixes="MyExtension" >

<xsl:value-of select="MyExtension:HelloWorld()" />



Binding the XML control to the XML Data

protected override void OnInit(EventArgs e)
    {
        if (!this.IsPostBack)
        {
            string xmlContent = "xml data goes here";
            XsltArgumentList list = new XsltArgumentList();
            Utils.XslHelper ext = new Utils.XslHelper();
            list.AddExtensionObject("http://www.sitecore.net/Utils", ext);
            Xml1.TransformArgumentList = list;
            Xml1.DocumentContent = xmlContent;
        }
    }

It turns out that, even though I had previously registered the xsl extension in the xslt file, I also had to register it via code as well. Otherwise, the following exception occurs at runtime.

Cannot find the script or external object that implements prefix 'MyExtension'.

Sorted!

Tags: ,

.Net | Asp.Net | Sitecore | Tips & Tricks

Bold style for matching results with AutoCompleteExtender - Implemented using a Trie

by aboo bolaky 7. October 2009 18:22

This article will focus on the implementation of the AjaxControlToolkit's AutoCompleteExtender into a simple ASP.NET application. What I'm trying to do here is pull the data from a database and use the AutoCompleteExtender to display the data as the user types characters in a textbox.

Server Implementation

Im not going to focus on how to retrieve the data (from a table of around 60,000 records). I'm going to use the simplistic SQLConnection/SQLCommand/SQLDataReader classes and passing sql command as plain text (as opposed to Stored Procedures). The key issue is how and what is the best way to store the data once being retrieved. Generally, Autocomplete comes in 2 flavours:-

1: Find words based on letters anywhere in a phrase (performing a LIKE '%ar%'  in SQL).

2: Find words that start with specific characters ( LIKE 'ar%' in SQL).

In the first instance, you're pretty much tied up to using the LIKE clause (be it in a stored proc or simple text). The determining factor here is how and when to cache the data since each character typed in invokes the webservice and queries the database. Each query will yield a different result set.

In the second instance (the focus of this article), the more you add characters to the keyword, you are, in fact, narrowing down the scope of search. This means that the data we initially load is deterministic and hence we can cache it somewhere. But the real deal here is :which  data structure do we hold our words in? List<>, DataTable, Linked List??

Trie 

You might have already figured this one out. Anyway, a trie is an ordered tree data structure (a.k.a prefix tree) that stores the information about the contents of each node in the path from the root to the node, rather than the node itself. What this means is that each part between the root and any leaf represents a key and the goal is to find the key by traversing the tree.

Implementation

Eyal Mey-Tal has implemented a Trie structure in C#.Head to the CodePlex site to download it.

WebMethod to retrieve data

[WebMethod]
    public string[] GetNames(string prefixText, int count)
    {
        Trie trie = (Trie)Context.Cache["Trie"];
        if (trie == null)
        {
            trie = new Trie();
            using (SqlConnection con = new SqlConnection("server=(local);database=autocomplete;user id=xxx;Password=xxx;"))
            {
                SqlCommand cmd = new SqlCommand("select word from AutoCompleteData", con);
                cmd.CommandType = System.Data.CommandType.Text;
                con.Open();
                SqlDataReader dr = cmd.ExecuteReader();
                if (dr.HasRows)
                {
                    while (dr.Read())
                    {
                        trie.Add(dr.GetString(0));
                    }
                    con.Close();
                }
            }
            //simple caching here  
            Context.Cache["Trie"] = trie;
        }
        List list = trie.GetCompletionList(prefixText);
        return list.Take(count).ToArray();
    }

 

Setting up the AutoCompleteExtender was easy. To get the autocomplete working, I only had to modify a few of the extender's attributes (.e.g. CompletionSetCount, TargetControlID, ServicePath, ServiceMethod, DelimiterCharacters ..) and data was being returned as I typed in characters. However, making the extender look good was a different story.

Client-Side Implementation 

This is the bit where I'm open to suggestions. I'm no Javascript/JQuery expert but however, I finally got the extender working as I wanted it to. Characters relevant to the ones the user has typed become highlighted in the drop down list. It took me a while to dig this solution out. The javascript is awkward and needs to be refactored. Netherless, the solution works for IE and Firefox [ good enough for me :) ]

 

<%@ Page Language="C#" AutoEventWireup="true" CodeBehind="AutoComplete.aspx.cs" Inherits="AutoComplete.AutoComplete" %>
<%@ Register Assembly="AjaxControlToolkit" Namespace="AjaxControlToolkit" TagPrefix="cc1" %>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head id="Head1" runat="server">
    <title></title>
    <style>
        .autocomplete_completionListElement
        {
            margin: 0px !important;
            background-color: inherit;
            color: windowtext;
            border: buttonshadow;
            border-width: 1px;
            border-style: solid;
            cursor: 'default';
            overflow: auto;
            height: 200px;
            text-align: left;
            list-style-type: none;
            padding-left: 1px;
        }
        
        /* AutoComplete highlighted item */
        
        .autocomplete_highlightedListItem
        {
            background-color: #aaff90;
            color: black;
            padding: 1px;
            cursor: hand;
        }
        
        /* AutoComplete item */
        
        .autocomplete_listItem
        {
            background-color: window;
            color: windowtext;
            padding: 1px;
        }
    </style>
    <script type="text/javascript">

        function acePopulated(sender, e) {

            var behavior = $find('AutoCompleteEx');

            var target = behavior.get_completionList();
            if (behavior._currentPrefix != null) {
                var prefix = behavior._currentPrefix.toLowerCase();
                var i;
                for (i = 0; i < target.childNodes.length; i++) {
                    var sValue = target.childNodes[i].innerHTML.toLowerCase();
                    if (sValue.indexOf(prefix) != -1) {
                        var fstr = target.childNodes[i].innerHTML.substring(0, sValue.indexOf(prefix));
                        var pstr = target.childNodes[i].innerHTML.substring(fstr.length, fstr.length + prefix.length);
                        var estr = target.childNodes[i].innerHTML.substring(fstr.length + prefix.length, target.childNodes[i].innerHTML.length);
                        target.childNodes[i].innerHTML = "<div class='autocomplete-item'>" + fstr + '<B>' + pstr + '</B>' + estr + "</div>";
                    }
                }
            }

        }

        function aceSelected(sender, e) {
            var value = e.get_value();
            if (!value) {
                if (e._item.parentElement && e._item.parentElement.tagName == "LI")
                    value = e._item.parentElement.attributes["_value"].value;
                else if (e._item.parentElement && e._item.parentElement.parentElement.tagName == "LI")
                    value = e._item.parentElement.parentElement.attributes["_value"].value;
                else if (e._item.parentNode && e._item.parentNode.tagName == "LI")
                    value = e._item.parentNode._value;
                else if (e._item.parentNode && e._item.parentNode.parentNode.tagName == "LI")
                    value = e._item.parentNode.parentNode._value;
                else value = "";
            }
            var searchText = $get('<%=txtWord.ClientID %>').value;
            searchText = searchText.replace('null', '');

            sender.get_element().value = searchText + value;
        }
                                       
   
    </script>
</head>
<body>
    <form id="form1" runat="server">
    <asp:ScriptManager ID="ScriptManager1" runat="server">
    </asp:ScriptManager>
    <div style="text-align: center; margin-top: 200px">
        Search :
        <asp:TextBox ID="txtWord" runat="server" AutoComplete="off" Width="200px" />
    </div>
    <cc1:AutoCompleteExtender runat="server" BehaviorID="AutoCompleteEx" ID="autoComplete1"
        TargetControlID="txtWord" ServicePath="MyService.asmx" ServiceMethod="GetNames"
        MinimumPrefixLength="1" CompletionInterval="1000" EnableCaching="true" CompletionSetCount="20"
        CompletionListCssClass="autocomplete_completionListElement" CompletionListItemCssClass="autocomplete_listItem"
        CompletionListHighlightedItemCssClass="autocomplete_highlightedListItem" OnClientPopulated="acePopulated"
        OnClientItemSelected="aceSelected" DelimiterCharacters=";" ShowOnlyCurrentWordInCompletionListItem="true">
    </cc1:AutoCompleteExtender>
    </form>
</body>
</html>





Result

 

 

Downloads

The source code (with database script in ~/App_Data (around 60,000 records )) can be downloaded below.

AutoCompleteVS2008Sln.zip (4.84 mb)

Enjoy ....

Tags:

.Net | Asp.Net | Tips & Tricks

Building extension-less Urls in Sitecore

by aboo bolaky 4. October 2009 08:55

Our goal here is to build a Sitecore solution having links without the .aspx extension.(although accessing a page with a .aspx extension should STILL work)

To start ,you need

  • A LOT OF PATIENCE
  • Helicon ISAPI Rewrite Lite (the free one). Since I'm usingWindows 7 RC1 x64bit, I'll need to download the x64 bit flavour of Helicon Lite
  • A test Sitecore Application .. I will be using the Sitecore Starter Kit [Sitecore Starter Kit 6.0.0 rev.090203] as an my starting point.  (installed on IIS 7).

Before I start on implementing the solution, a little bit of background info would, I guess, be quite useful.

AddAspxExtension in LinkManager

A potential solution is to change the value of AddAspxExtension from true (by default) to false. If you do change it to false, you will have to create a wildcard script map to the ASP.NET runtime. This causes IIS to intercept every request made against the web server. This includes requests for images, asp.net pages and HTML pages. Therefore, enabling a wildcard script map to ASP.NET does have performance implications. If you wish to find another way to use pages without .aspx extensions in Sitecore, please read further....

Sitecore Aliases

Aliases, in a nutshell, allow you to shorten the url of an item. For example, if your item is currently accessible via http://hostname/MyParentItem/MyChildItem.aspx, you can specify an alias of myChildItem, which will be a placeholder for the actual item as it is in the Sitecore tree. Hence, the url of the alias is http://hostname/MyChildItem.aspx. For SEO purposes, this allows us to surface items from deep down in the hierarchy right up to the site root.

Note:

  • Aliases do not work if you remove the .aspx extension
  • No matter how far your items are in the sitecore tree, an alias allows you to refer to it from the site root.

Step 1: Install and Configure Helicon ISAPI Rewrite Lite

Start by installing Helicon ISAPI Rewrite. This process is fairly straightforward. Since we are using the lite version,  our Regex entries will be placed in the global http.conf (located in the Lite version installation folder). The entries in my httpd.conf are as follow:-

RewriteEngine on
RewriteBase /
RewriteRule ^(sitecore.*)$ $1 [L]
RewriteRule ^([^\.\?]+)/?(\?.*)?$ /$1.aspx$2 [L]

 

Url Rewriting Rationale

Before a request is forwarded to Sitecore, the ISAPI module intercepts it.

Line 1: You NEED that ! This turns on the Helicon ISAPI Module

Line 2: Errr...This is self-explanatory..

Line 3: We don't need to chop off the .aspx when we are in Sitecore CMS. For this reason, we're basically telling the module to not do anything when a request has "sitecore" in it.

Line 4: This is the most important bit. This appends .aspx (and querystrings,if any) to requests and consequently forwards the resulting request to Sitecore. Two scenarios arise as a result of this.

 3.1 : Sitecore maps the request to an item in the database. The page gets displayed in the end.

 3.2 : Sitecore cannot find the item based on the url. You will either end up with the  Sitecore's "Item Not Found" page.

NB:

Before we go any further, I need to confess that I did modify the Starter Kit a little prior to this operation. Basically, when you load the starter kit, you are greeted with a dummy home Site, that has a nice layout and there is a link to the Actual Starter Site. I was tired of this as my home page, So, I changed the value of "startItem" [in the Sites Definition of website (in web.config)] from "/home" to "/Sample". In that way, when i hit the website, I will eventually land on the real starter site!. Also, by doing so, all my urls within the website will no longer contain "/sitecore/content/.." since the Start Item has changed.

Quick Test on Urls

Request : http://sitecorestarterkit/References.aspx  [OK]

Request : http://sitecorestarterkit/References  [OK]

Request : http://sitecorestarterkit/Services/Architectual-Services.aspx [OK]

Request : http://sitecorestarterkit/Services/Architectual-Services [OK]

Request : http://sitecorestarterkit/Sitecore/  [OK..CMS access]

It looks like we have a half-baked solution. Aliases will now work without the .aspx extension as well. The other bits that need to be considered are

1 : How to make sitecore controls (.e.g. sc:link etc..) aware that they should drop the ".aspx" extensions

2 : How does it all tie up together with .NET (user controls etc..)

Step 2: XSL Extensions (revised)

To follow up on custom solution, you will need to tell Sitecore to remove the ".aspx" when it renders urls (either via sc:link [xsl extensions] or c# code). For XSL Extensions, we need to disable the default implementation that Sitecore provides us with and roll out our own. Fortunately, it's very easy to do so. [Credits : Chris Wojciech ]

 

2.1 : Turn off the default XslHelper

<xslExtensions>
<!-- Changed from "On" to "Off" -->
<extension mode="off" type="Sitecore.Xml.Xsl.XslHelper, Sitecore.Kernel" 
	namespace="http://www.sitecore.net/sc" singleInstance="true" />
	......
</xslExtensions>

  

  

2.2 : Create your own XslHelper

 namespace Starterkit.Utils
 {
	 public class XslHelper : Sitecore.Xml.Xsl.XslHelper
	{
		public override string path(System.Xml.XPath.XPathNodeIterator iterator)
		{
			string path = base.path(iterator);
			string newPath = Regex.Replace(path, ".aspx", String.Empty, RegexOptions.IgnoreCase | RegexOptions.Compiled);
			return newPath;
		}
		public override string link(string fieldName, System.Xml.XPath.XPathNodeIterator iterator, string parameters)
		{
			string path = base.link(fieldName, iterator, parameters);
			string newPath = Regex.Replace(path, ".aspx", String.Empty, RegexOptions.IgnoreCase | RegexOptions.Compiled);
			return newPath;
		}
		public override string StartLink(System.Xml.XPath.XPathNodeIterator iterator, string parameters)
		{
			string path = base.StartLink(iterator, parameters);
			string newPath = Regex.Replace(path, ".aspx", String.Empty, RegexOptions.IgnoreCase | RegexOptions.Compiled);
			return newPath;
		}
 
	}
}

 

For each of those three methods, we're only replacing the .aspx with an empty string. To enable <sc:link/> to use our custom Xsl Helper, we need to add another entry to the <xslextensions> section

 

<xslExtensions>
	<!-- Changed from "On" to "Off" -->   
	<extension mode="off" type="Sitecore.Xml.Xsl.XslHelper, Sitecore.Kernel" 
	namespace="http://www.sitecore.net/sc" singleInstance="true" />  
	<extension mode="on" type="Starterkit.Utils.XslHelper, Starterkit.Utils"
	 namespace="http://www.sitecore.net/sc" singleInstance="true" />
	 ....... 
 </xslExtensions>
 

 

NEARLY THERE!!!. All the links (that are rendering using sc:link) have now lost the .aspx extensions on the front end.

Step 3 : Sitecore and .NET interaction (with Url Rewriting)

If you have a Sitecore solution built using XSLT renderings only (highly unlikely though..), you're kinda safe here. However, if you have usercontrols (that host controls that can cause a postback) as well (for argument's sake, a contact us form), you end up with one issue.

Let's create a Contact Us form and add it to the presentation of the Contact Us item in Sitecore

 

User Control Designer

 <%@ Control Language="c#" AutoEventWireup="true"
 TargetSchema="http://schemas.microsoft.com/intellisense/ie5" 
 Inherits="Layouts.Contactus.ContactusSublayout"
 Codebehind="~/layouts/Starter Kit/Sublayouts/ContactUs.ascx.cs" %>
 
 <asp:Label Text="First Name : "  AssociatedControlID="txtFirstName" runat="server" />
 <asp:TextBox ID="txtFirstName" runat="server" />
 <asp:Label Text="First Name : "  AssociatedControlID="txtFirstName" runat="server" /> 
 <asp:TextBox ID="TextBox1" runat="server" />
 <asp:Button ID="btnSend" Text="Send" runat="server" />
  
   

 

Page Source

 <form name="mainform" method="post"
 action="/Contact.aspx" id="mainform">
 


To solve this, you will need to create a Control Adapter for the Forms in your application. Control Adapters allow you to inject custom code within the rendering of a control.

 

Form Control Adapter

namespace Starterkit.Utils
{
	public class FormActionRewriter : System.Web.UI.Adapters.ControlAdapter
	{
		protected override void Render(System.Web.UI.HtmlTextWriter writer)
		{
			base.Render(new RewriteFormHtmlTextWriter(writer));
		}
  	}
	class RewriteFormHtmlTextWriter : HtmlTextWriter
	{
		public RewriteFormHtmlTextWriter(HtmlTextWriter writer)
			: base(writer)
		{
			this.InnerWriter = writer.InnerWriter;
		}
 		public RewriteFormHtmlTextWriter(System.IO.TextWriter writer)
			: base(writer)
		{
			base.InnerWriter = writer;
		}
		public override void WriteAttribute(string name, string value, bool fEncode)
		{
 			if ((name == "action"))
			{
				HttpContext Context = null;
				Context = HttpContext.Current;
 
				if (Context.Items["ActionAlreadyWritten"] == null)
				{
					if ((!Context.Request.RawUrl.Contains("sitecore")))
					{   //remove .aspx extension if we're on the front end
						value = Regex.Replace(Context.Request.RawUrl, ".aspx", String.Empty, RegexOptions.IgnoreCase | RegexOptions.Compiled);
						Context.Items["ActionAlreadyWritten"] = true;
					}
				}
 			}
			base.WriteAttribute(name, value, fEncode);
		}
	}
}

Add Form Control Adapter in Solution

Open the form.browser (located in ~/App_Browsers) and add the new entry

<browsers> 
	<browser refID="Default">
		<controlAdapters>    
			<adapter controlType="System.Web.UI.HtmlControls.HtmlForm" 
			adapterType="Sitecore.Web.FormAdapter, Sitecore.Kernel" />  
			<!--Added--> 
			<adapter controlType="System.Web.UI.HtmlControls.HtmlForm"
			adapterType="Starterkit.Utils.FormActionRewriter, Starterkit.Utils" />    
		</controlAdapters> 
	</browser>
</browsers>

THIS IS IT!!!

<form name="mainform" method="post"
 action="/Contact" id="mainform">

 

RESULT !!! .... Back to Sitecore :)

Tags: ,

.Net | Applications | Sitecore

Best way to parse HTML content

by aboo bolaky 23. September 2009 08:26


I'm going to keep this short and simple..rather short actually.

There is no better way to parse HTML other than using HtmlAgility Pack.

It's a lot simpler than Regex..which is a BIG no no!!

 

Tags:

.Net | Asp.Net | Freebies

SEO Friendly Urls in Sitecore -Remove spaces in Url (3)

by aboo bolaky 11. August 2009 06:33

It's the third time I'm writing on this particular topic (The EncodeNameReplacements element in the web.config). Articles 1 and 2  have had their importance in building SEO-friendly links in Sitecore.

Double Encoding in Urls

Whilst doing some routine administrative tasks in sitecore, I noticed that some links were no longer working. I was pretty sure that those links were working before I did a publish. :( Back to the drawing board.

As outlined in Articles 1 and 2, I was using

<replace mode="on" find=" " replaceWith="-" />

in my web.config. It was working fine when sitecore items were having names like "Camera one" (->url: camera-one.aspx), "Camera one two three" (->url: camera-one-two-three.aspx) etc...

However, if an item name has a character that has already been defined in my EncodeNamesReplacements section, Sitecore throws you back on the Item Not Found page. In my situation, I had renamed the Sitecore Item :"John Doe" to "John-Doe" (lame administrative task...I KNOW) . The effect of this is that when the user clicks on the John-Doe.aspx, he/she is redirected to the default "Item Not Found" sitecore page. A careful look at the url has revealed that Sitecore was trying to request an item with a name of John--Doe and consequently failed.

Solution

or hack (for some people)

If you are using a specific character to get rid of spaces in url, you need to make sure that a cms user will not be able to create an item name having that character in. Easy way to factor this in is to include your character in the InvalidItemNameChars element in the web.config. In my implementation, I've changed that setting to :

<setting name="InvalidItemNameChars"
	value="\/:?&quot;&lt;&gt;|[]-/>

 

and that did the trick :)

Tags: ,

.Net | Applications | Sitecore

Implementing Sitecore Extranet login on a website

by aboo bolaky 30. July 2009 08:02

Here's the situation. You are about to implement a password protected area on your website. Let's assume that the general site structure looks like this

Pages below General and Products are accessible to everyone, whereas pages under Members should only be visible to authenticated/logged in members. I will first briefly outline the steps required to get this problem implemented using ASP.NET. Later on, I'll move onto it's equivalent Sitecore Solution.

Using ASP.NET

  • Implement Forms Authentication and set login url in the web.config.
  • Implement Login control and decide where to retrieve and store login credentials (in web.config or database)
  • In the web.config, add a Location Path pointing to the Members folder (Deny anonymous , allow authenticated users )
  • This is all about it really...(as far as I remember..) ...

In Sitecore, it's a different ball game.

In addition to adding the loginURL to the form authentication section (important if you use the loginview control to show the login page), you will need to  add the  "loginPage" attribute to the site which is defined by your extranet domain (normally, it's called "website" )

	
<sites>
 .....
	<site name="website" virtualFolder="/" physicalFolder="/" 
		loginPage="/General/Login.aspx"
  ....
</sites>

 

The LoginPage attribute is not something new here..It has always been there..(e.g. the shell website has already a loginPage set), but i did not know what was its purpose . Thanks to Chris Wojciech, I've discovered how to use this existing functionality in the web application.

The addition of Location path in the asp.net-only model is analogous to denying read access to the Members folder (+descendants) in Sitecore.

 

Once you perform a site publish, you can see the effects straight away.

If you've already signed in, you will be able to view /Members/View My Account.aspx.

If you're an anonymous user and access  /Members/View My Account.aspx, you will be presented with a default page that Sitecore serves in case access is denied due to security privileges.

http://mywebapp/sitecore/service/noaccess.aspx?item=%2fmembers%2fview+my+account&user=extranet%5cAnonymous&site=website

 

Quick Fix :

The page served in this case is called noaccess.aspx. The good thing is that this can be altered by changing the value of the "NoAccessUrl" attribute in the web.config.

If we set  "NoAccessUrl" to "/General/Login.aspx", we end up in this situation

http://mywebapp/general/login.aspx?item=%2fmembers%2fview+my+account&user=extranet%5cAnonymous&site=website

 

Recommended Solution

The nag in the above quick fix is that sitecore internally adds 3 QueryStrings to the url ( item, user and site). If we compare this to the normal ASP.NET solution, we would have ended up with only 1 querystring, which is the ReturnUrl.  Our goal is to follow the asp.net solution as close as possible. This is where Chris comes in..

Rolling out your own Security Resolver

Chris extended the HttpRequestProcessor class in order to intercept the request ,check if the user requesting the sitecore item has appropriate rights. If that is not the case, the user is redirected to the login page, with the appropriate ReturnUrl QueryString. Please go check the code out on his blog at http://blog.wojciech.org/?p=64 

The processor should then be plugged in the web.config, before the definition of the ExecuteRequest processor.

 

<processor type="Sitecore.Pipelines.HttpRequest.ItemResolver, Sitecore.Kernel"/>
<processor type="Sitecore.Pipelines.HttpRequest.LayoutResolver, Sitecore.Kernel"/>
<processor type="MyWebApp.Pipelines.MyOwnSecurityResolver, MyWebApp"/>
<processor type="Sitecore.Pipelines.HttpRequest.ExecuteRequest, Sitecore.Kernel"/>

 

If you now try to access a protected page as an anonymous user, you'll end up on the login page (but this time, the ReturnUrl parameter has replaced the 3 built-in sitecore url parameters)

http://mywebapp/general/login.aspx?returnUrl=/members/view%20my%20account.aspx

Result :)

Tags: ,

.Net | Applications | Sitecore

LoginView control not working when logging out from Sitecore extranet domain

by aboo bolaky 29. July 2009 06:19

Let's not re-invent the wheel and make use of the ASP.NET 2.0 LoginView control to generate Login/Logout actions for the Sitecore extranet domain.

We have our LoginView control (very simplistic example given here) in a sublayout.

<asp:LoginView ID="loginView" runat="server">
	<AnonymousTemplate>
	  Welcome Guest <asp:LoginStatus runat="server" LoginText="Login" />
	</AnonymousTemplate>
        
	<LoggedInTemplate>
	  Welcome <%= Sitecore.Context.User.Name %>.
	  <asp:LoginStatus runat="server" LogoutText="Logout"
	   LogoutPageUrl="/" LoginText="Login" LogoutAction="Redirect" />
	</LoggedInTemplate>
</asp:LoginView>

LoginView Control Caveat

The LoginView control "magically" knows the login page url. This is specified by the LoginUrl attribute in the FormsAuthentication section of the web.config. This is not to be confused the LoginPage attribute (from the sites section). I had to modify my web.config to

 <authentication mode="Forms">
   <forms name=".ASPXAUTH" cookieless="UseCookies" 
		loginUrl="~/General/Login.aspx" />
 </authentication>

Erractic Behaviour when logging out

I did not experience any problems when logging in .i.e. the control did what is was supposed to do (display sitecore username and Logout Link). HOWEVER, when I pressed the Logout link, I always got redirected the Sitecore Layout page instead. I did spot similar behaviour with ListViews in Sitecore (also documented by Paul George and Mark Cassidy, where its events were not being fired at all. I've made the following change to my web.config and that solved the problem :)

<typesThatShouldNotBeExpanded>
   <type>System.Web.UI.WebControls.Repeater>/type>
   <type>System.Web.UI.WebControls.DataList>/type>
   <type>System.Web.UI.WebControls.LoginView>/type>
</typesThatShouldNotBeExpanded>

 

A similar problem that relates to the  typesThatShouldNotBeExpanded tag has also been documented on SDN

Tags: ,

.Net | Applications | Sitecore

Automatic Publishing in Sitecore

by aboo bolaky 26. July 2009 07:02

Sitecore DOES support Automatic Publishing. However, there are not many instances where you would want Sitecore to automatically perform a publish.

The values to change reside in the web.config, right where you have definitions for the scheduling and agents

<agent type="Sitecore.Tasks.PublishAgent" method="Run" interval="00:00:00">
	<param desc="source database">master</param>
	<param desc="target database">web</param>
	<param desc="mode (full or incremental)">incremental</param>
	<param desc="languages">en, da</param>
</agent>

 

I guess that a value of "00:00:00" for the interval attribute does disable automatic publishing. If you set the value to (say..10 minutes) "00:10:00", you will notice that after 10 minutes or so, changed items from the master database will be copied over to the web database.

Automatic publishing is useful where you have integrated external datasources in sitecore (using Data Providers) and where there needs to be a predefined process that synchs the external data to the web database. For the automatic publishing to work in this particular situation, you must have had created a new database entry (with a reference to your data provider) in the web.config.

Sitecore Data Providers....hmmmmm...that's upcoming.... :)

Tags: ,

.Net | Applications | Sitecore

Tag cloud

Flash Player 9 required.

About Me

I wish I could write something here..
//TODO: ElaborateMe